Plamo Linux 日記

Plamo Linux に関係することだけではなく,最近は一般的なコンピュータやガジェット関係についても記載してます.

cakephp 3.6.x 用にコード修正の作業をボチボチと (その3)

cakephp 3.6.x の様子をみながら Deprecated って言われるコードをボチボチと修正してます.

「手元のコード修正もほぼ終わったので,これで問題なく 4.0.0 を迎えられそうな感じかな.」って書きましたが,詳細チェックしてたらダメダメなところがまだまだありました.

Deprecated ってメッセージが表示されない個所でも引っ掛かる記述が結構あるんだね.

TableRegistry::get() が TableLocator::get() になったり,eventManager がなくなったりとか.

cookbook には記載がないので,API (https://api.cakephp.org/3.6/) の方をチェックしないとダメみたいだな.

まぁ,メッセージが出ないところはボチボチと修正することにして,とりあえず 3.6.x 系列に移行するか.