Plamo Linux 日記

Plamo Linux に関係することだけではなく,最近は一般的なコンピュータやガジェット関係についても記載してます.

cakephp 3.4.x ってそのまま簡単にアップデートできないのね

cakephp 3.3.x 系から cakephp 3.4.x 系に移行のために少し作業.

これまでと同じ流れて,何も考えずに composer.json の "cakephp/cakephp" を "3.4.0" に変更して composer update でオッケーなのかな.と思ったらエラー出まくり.3.4.0 のリリースノートにあった

% php composer.phar require "cakephp/cakephp:3.4.0"

とかでも aura/intl などが衝突してアップデートできないですね.いろいろと修正しないとだめらしい.

なにかと周辺ツールの要求バージョンがかなり上がってるみたいで,いろいろと問題が.

うーむ.

仕方がないので手作業で再び composer.json をぽちぽちと作成.

で,composer update して全部入れかえ.なんとなく動作しているみたい.

あとは 3.4 Migration Guide をみながら,該当箇所を書き換えかな.

PHPフレームワーク CakePHP 3入門
掌田 津耶乃
秀和システム